Page MenuHomePhabricator

Alternative wording/organization for the new policy
Needs ReviewPublic

Authored by mehdi_amini on Jan 15 2019, 8:36 PM.
This revision needs review, but there are no reviewers specified.

Details

Reviewers
None
Summary

This *not* a patch intended to be submitted, it is a stripped-down version of how I'd phrase the policy change proposed here: https://reviews.llvm.org/D47073

This intentionally left out any compiler minimum bump out of the policy upgrade change, as these are conceptually separate change anyway.

Event Timeline

mehdi_amini created this revision.Jan 15 2019, 8:36 PM
mehdi_amini marked 2 inline comments as done.Jan 15 2019, 8:41 PM
mehdi_amini added inline comments.
llvm/cmake/modules/CheckCompilerVersion.cmake
10

Note in this version: the _MIN can't be ignored, the _WARN can be ignored and is only here to support the "one release cycle deprecation".

llvm/docs/GettingStarted.rst
241

Added explicit policy that we'll give a one release cycle.

mehdi_amini edited the summary of this revision. (Show Details)Jan 15 2019, 8:44 PM
jfb added a subscriber: jfb.Jan 15 2019, 9:29 PM
jfb added inline comments.
llvm/cmake/modules/CheckCompilerVersion.cmake
10

How did you choose these numbers? Which version of C++ do they allow moving to?

mehdi_amini marked an inline comment as done.Jan 15 2019, 9:40 PM
mehdi_amini added inline comments.
llvm/cmake/modules/CheckCompilerVersion.cmake
10

I don't know if I understand your question correctly?
As I mentioned in the description: "This intentionally left out any compiler minimum bump out of the policy upgrade change, as these are conceptually separate change anyway."

So these numbers are exactly the same as the current one, this diff is *only* setting the structure for the change, not settling the question of which numbers to pick.

jfb added inline comments.Jan 15 2019, 9:46 PM
llvm/cmake/modules/CheckCompilerVersion.cmake
10

That's the important part of D47073! The version bump was chosen through extensive discussion, which I've linked to. I appreciate that you're clarifying your suggestion with code, but please read up on that discussion.