This is an archive of the discontinued LLVM Phabricator instance.

[analyzer] Rename trackNullOrUndefValue to trackExpressionValue
ClosedPublic

Authored by george.karpenkov on Oct 1 2018, 5:34 PM.

Details

Summary

trackNullOrUndefValue is a long and confusing name,
and it does not actually reflect what the function is doing.
Give a function a new name, with a relatively clear semantics.

Also remove some dead code.

Diff Detail

Repository
rL LLVM

Event Timeline

NoQ added a comment.Oct 1 2018, 6:12 PM

I'd prefer to keep the word Value in the name, i.e. trackValue() or trackExpressionValue(). It just doesn't make much sense to track the expression itself or find its origin - instead, we're figuring out where did its value come from.

clang/include/clang/StaticAnalyzer/Core/BugReporter/BugReporterVisitors.h
349 ↗(On Diff #167863)

Is this intended?

george.karpenkov retitled this revision from [analyzer] Rename trackNullOrUndefValue to trackExpression to [analyzer] Rename trackNullOrUndefValue to trackExpressionValue.
george.karpenkov edited the summary of this revision. (Show Details)
george.karpenkov marked an inline comment as done.
Szelethus added inline comments.Oct 2 2018, 3:09 PM
clang/include/clang/StaticAnalyzer/Core/BugReporter/BugReporterVisitors.h
348 ↗(On Diff #168035)

Is it not the value of an expression?

NoQ accepted this revision.Oct 19 2018, 5:34 PM

Let's commit? :)

clang/include/clang/StaticAnalyzer/Core/BugReporter/BugReporterVisitors.h
348 ↗(On Diff #168035)

+1 :)

This revision is now accepted and ready to land.Oct 19 2018, 5:34 PM
george.karpenkov marked an inline comment as done.Oct 23 2018, 11:01 AM
This revision was automatically updated to reflect the committed changes.