There's some additional macro fusion opportunities on newer apple CPUs.
Would it be better to give a more operational name (e.g. FuseAESCrypto?) along with a comment if it applies to only certain configs. Just a thought, I am ok with as it is as well.
IIUC, this new feature is an extension of FeatureFuseAES. Therefore, I think that it'd be better if it were just about the new fusion, namely of PMULL and EOR.
Thereby retaining FeatureFuseAES here and adding the new feature.
The first two cases repeat isAESPair(), so methinks that it'd be better if it'd check only the new pair, PMULL AND EOR.
Yeah we already had FuseAES and I was just implementing another variation of it, hence my original try with "Apple" in the name. But indeed describing it more function like "CryptoEOR" turned out to look better.
ok, reused FeatureFuseAES this time and called the new thing FuseCryptoEOR.