This NFCI patch moves a static helper function into the TargetLoweringInfo class, so that it can be reused by other classes. I intend to call this new function, called getStrictOperationAction(...), from VectorLegalizer in the near future.
Is there a reason for dropping the "FP" from "StrictFP" in the method name? I think it would be better to keep it (i.e. use "getStrictFPOperationAction"), in particular since there are already other public methods in this area that use "StrictFP", like isStrictFPOpcode and MutateStrictFPToFP.
Otherwise this LGTM.