Page MenuHomePhabricator

Rename DynamicReloc::getAddend() to computeAddend(). NFC

Authored by arichardson on Feb 10 2018, 10:17 AM.



Before the name of the function sounded like it was just a getter for the
private class member Addend. However, it actually calculates the final value
for the r_addend field in Elf_Rela that is used when writing the .rela.dyn section.
I also added a comment to the UseSymVA member to explain how it interacts
with computeAddend().

Diff Detail


Event Timeline

arichardson created this revision.Feb 10 2018, 10:17 AM
arichardson retitled this revision from Rename DynamicReloc::getAddend() to getRelaAddend(). NFC to Rename DynamicReloc::getAddend() to computeAddend(). NFC.
arichardson edited the summary of this revision. (Show Details)

Addressed review comment

This revision was not accepted when it landed; it landed in state Needs Review.Feb 19 2018, 3:02 AM
This revision was automatically updated to reflect the committed changes.