Page MenuHomePhabricator

[asan] Restore asan_device_setup compatibility with older libraries.
ClosedPublic

Authored by eugenis on Jan 2 2018, 1:26 PM.

Details

Summary

This way new asan_device_setup, which knows about the quirks of
recent releases of Android, can be used with older ASan runtime
library (say, from an NDK release). The library is version locked to
the compiler, and is often hard or impossible to update.

Diff Detail

Repository
rL LLVM

Event Timeline

eugenis created this revision.Jan 2 2018, 1:26 PM
vitalybuka accepted this revision.Jan 2 2018, 1:34 PM
This revision is now accepted and ready to land.Jan 2 2018, 1:34 PM
This revision was automatically updated to reflect the committed changes.