instead of using a boolean to differentiate between the two section
types, use an enum to make the intent clearer.
I also remove the RegisterKind argument from the constructor, as this
can be deduced from the Type argument.
Paths
| Differential D34681
[DWARFCallFrameInfo] Add Type enum to differentiate eh/debug_frame sections ClosedPublic Authored by labath on Jun 27 2017, 4:33 AM.
Details
Summary instead of using a boolean to differentiate between the two section I also remove the RegisterKind argument from the constructor, as this
Diff Detail
Event TimelineThis revision is now accepted and ready to land.Jun 27 2017, 9:44 AM Comment Actions Saying about clear intent, it would be even much more better if class name doesn't start with DWARF ;) Comment Actions
That's probably true. :) However, I think I've done enough of renaming of files lately that I will pass on this one for now. Closed by commit rL306521: [DWARFCallFrameInfo] Add Type enum to differentiate eh/debug_frame sections (authored by labath). · Explain WhyJun 28 2017, 2:09 AM This revision was automatically updated to reflect the committed changes.
Revision Contents
Diff 104362 lldb/trunk/include/lldb/Symbol/DWARFCallFrameInfo.h
lldb/trunk/source/Plugins/ObjectFile/Mach-O/ObjectFileMachO.cpp
lldb/trunk/source/Symbol/DWARFCallFrameInfo.cpp
lldb/trunk/source/Symbol/UnwindTable.cpp
lldb/trunk/unittests/Symbol/TestDWARFCallFrameInfo.cpp
|