The current name (addModulePath) and return value
(ModulePathStringTableTy::iterator) is a little confusing. This
API adds a module, not just a path. And the iterator is basically
just an implementation detail of the summary index. Address
both of those issues by renaming to addModule and introducing a
ModuleSummaryIndex::Module type that the function returns.
Details
Details
Diff Detail
Diff Detail
- Build Status
Buildable 7172 Build 7172: arc lint + arc unit
Event Timeline
Comment Actions
LGTM
llvm/include/llvm/IR/ModuleSummaryIndex.h | ||
---|---|---|
694 | I have a preference towards naming this something other than Module, since that name is so frequently used for the IR Module. Consider changing to something like ModuleInfo or something like that? (And if you do so, the change to hasExportedFunctions parameter can be reverted) |
llvm/include/llvm/IR/ModuleSummaryIndex.h | ||
---|---|---|
694 | Renamed to ModuleInfo. |
I have a preference towards naming this something other than Module, since that name is so frequently used for the IR Module. Consider changing to something like ModuleInfo or something like that? (And if you do so, the change to hasExportedFunctions parameter can be reverted)