getSignBit is a static function that creates an APInt with only the sign bit set. getSignMask seems like a better name to convey its functionality. In fact several places use it and then store in an APInt named SignMask.
I would like to use the getSignBit name as a method that returns the sign bit of an APInt providing the same information as isNegative(). This would be used in places in ValueTracking that currently use KnownZero.isNegative(). KnownZero and negative in the same statement is somewhat confusing as KnownZero.isNegative() mean that the sign bit is known to be 0 meaning the value being tracked is non-negative.
So rather than having two very different getSignBit methods/functions, I'd like to rename the static one first.