Page MenuHomePhabricator

[lldb][cmake] Remove dependency on libLLVMCoverage (NFCI)
AcceptedPublic

Authored by vsk on Jul 29 2016, 5:15 PM.

Details

Summary

This should also eliminate the libLLVMProfileData dependency, which cuts
down on the build time nicely.

This passes check-lldb.

This could lead to a functional change if lldb needs to compile *and*
instrument code, but I don't see this done anywhere and I can't imagine
a situation where this would be needed.

Diff Detail

Event Timeline

vsk updated this revision to Diff 66204.Jul 29 2016, 5:15 PM
vsk retitled this revision from to [lldb][cmake] Remove dependency on libLLVMCoverage (NFCI).
vsk updated this object.
vsk added reviewers: zturner, spyffe, clayborg.
vsk added a subscriber: llvm-commits.
clayborg accepted this revision.Nov 22 2016, 9:22 AM
clayborg edited edge metadata.

I am fine with this as long as all the buildbots are happy. Watch the builders closely if you commit this.

This revision is now accepted and ready to land.Nov 22 2016, 9:22 AM