Patch adds support for the intrinsics mrrc/mrrc2 and updates the existing mcrr/mcrr2 intrinsic definition to accept a single uint64 type as the input value instead of 2 uint32's as I think this makes the definition more compact.
Details
Diff Detail
Event Timeline
lib/CodeGen/CGBuiltin.cpp | ||
---|---|---|
3817 | Would be better to use the comments as names and avoid the comments... It'd also make clear the casts below. | |
3824 | These variables could have better names... | |
3846 | Same here | |
test/CodeGen/builtins-arm.c | ||
203–206 | I'm assuming this is a "soon to be documented" move, right? It's really hard to review patches with these things changing all the time... |
test/CodeGen/builtins-arm.c | ||
---|---|---|
203–206 |
Yes I've written the document myself which defines these intrinsics.
Sorry, I didn't know these sorts of thing change that often. |
Hi Renato,
please look again at this patch, I've addressed your comments.
Thanks,
Ranjeet
Would be better to use the comments as names and avoid the comments...
It'd also make clear the casts below.