It allows to standardize common checks and unify error messages.
Details
Details
Diff Detail
Diff Detail
Event Timeline
Comment Actions
LGTM for me, but please wait to see what Rui thinks.
There is a few extra functions to look at, but there are many uses of them, which makes for a good tradeoff IMHO.
ELF/Target.cpp | ||
---|---|---|
45 | checkIsInt -> checkInt | |
46–48 | It's a minor point, but I don't like to mix strings with getElfRelocationTypeName() function call because the function name is too long. I'd write like this. if (isInt<N>(V)) return; StringRef S = getELFRelocationTypeName(Config->EMachine, Type); error("Relocation " + S + " out of range"); | |
51 | Ditto | |
57 | Ditto |
checkIsInt -> checkInt
Val -> V