At some point PlatformInfo's Target changed types to a type that also
has minimum deployment target info. This caused ambiguity if you tried
to get the target triple from the Target, as the actual minimum version
info was being stored separately. This bulk of this change is changing
the parsing of these values to support this.
Details
- Reviewers
int3 - Group Reviewers
Restricted Project - Commits
- rG6578e0d1d0e4: [lld-macho] Remove duplicate minimum version info
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
lld/MachO/Driver.cpp | ||
---|---|---|
686–687 | can we set both platformInfo and secondaryPlatformInfo in this function, and make it return void? It doesn't seem like return them as values helps readability + I would like to avoid std::pair as much as possible (again for readability). remember to update the "side-effect" comment above as well :) | |
688 | while we're here, could we change this to a DenseMap or IndexedMap? Doesn't really matter for perf but we try to avoid std::map in general. And this might save some binary size | |
lld/test/MachO/tapi-link.s | ||
20 | I think we should not put NFC in the commit title. Minor change but a change nonetheless... |
update function to mutate instead of return
lld/MachO/Driver.cpp | ||
---|---|---|
688 | it looks like both of those have new requirements for the key type, I will do it in a separate change to avoid noise in this diff |
Thanks Keith!
lld/MachO/Driver.cpp | ||
---|---|---|
688 | ah ok. No worries either way, it's not super important |
can we set both platformInfo and secondaryPlatformInfo in this function, and make it return void? It doesn't seem like return them as values helps readability + I would like to avoid std::pair as much as possible (again for readability).
remember to update the "side-effect" comment above as well :)