Page MenuHomePhabricator

[ARM] Support for ARMv6-Z / ARMv6-ZK missing
ClosedPublic

Authored by tyomitch on Sep 29 2015, 2:34 AM.

Details

Summary

As @richard.barton.arm observed at http://reviews.llvm.org/D12937#inline-107121 TargetParser in LLVM has insufficient support for ARMv6Z and ARMv6ZK.

In particular, there were no tests for TrustZone being supported in these architectures.

The patch clears a FIXME: left by @compnerd in r201471, and fixes his test case which hadn't really been testing what it was claiming to test.

Diff Detail

Repository
rL LLVM

Event Timeline

tyomitch updated this revision to Diff 35947.Sep 29 2015, 2:34 AM
tyomitch retitled this revision from to [ARM] Support for ARMv6-Z / ARMv6-ZK missing.
tyomitch updated this object.
compnerd added inline comments.Sep 29 2015, 6:41 PM
test/MC/ARM/directive-arch_extension-sec.s
35 ↗(On Diff #35947)

This seems in conflict with the line above.

tyomitch added inline comments.Sep 30 2015, 2:42 AM
test/MC/ARM/directive-arch_extension-sec.s
35 ↗(On Diff #35947)

Quite the opposite: this is to check that only one "error: instruction requires: TrustZone" is emitted.

As this test case doesn't use labels, the line above may otherwise match an error emitted from the first part of the test.

compnerd accepted this revision.Sep 30 2015, 8:38 AM
compnerd edited edge metadata.

Ah, right. Can we get away with a CHECK-V7-NEXT-NOT? Either way, the patch looks fine.

This revision is now accepted and ready to land.Sep 30 2015, 8:38 AM
This revision was automatically updated to reflect the committed changes.