Details
Details
- Reviewers
• Quuxplusone ldionne - Group Reviewers
Restricted Project - Commits
- rGf75f171b2050: [libc++] Remove cpp17_input_iterator.h
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Unit Tests
Event Timeline
Comment Actions
Seems plausible to me, but why on earth does this file exist? Shouldn't whoever-uses-it just be using test/support/test_iterators.h instead?
I notice that the header guard's name is incorrect too, and I assume that's simply an artifact of this file's getting accidentally caught up in the big input_iterator->cpp17_input_iterator rename circa last year.
Could you dig into whether we can just use test_iterators.h in the appropriate places and git rm this file?
Comment Actions
Awesome, LGTM if CI is green.
Pre-existing issues that could be worth fixing in a followup PR if you're interested:
- iter_alloc.pass.cpp should be named iter_iter.pass.cpp/iter_iter_alloc.pass.cpp.
- It should test all the different test iterators, not just It=char* and It=cpp17_input_iterator<const char*>.
- It should be refactored in the obvious way to test<It>() instead of test(It, It), to cut down on repetition.