Page MenuHomePhabricator

[lldb/lua] Force Lua version to be 5.3
ClosedPublic

Authored by siger-young on Aug 21 2021, 4:59 PM.

Details

Summary

Due to CMake cache, find_package in FindLuaAndSwig.cmake
will be ignored. This commit adds EXACT and REQUIRED flags
to it and removes find_package in Lua ScriptInterpreter.

Signed-off-by: Siger Yang <sigeryeung@gmail.com>

Diff Detail

Event Timeline

siger-young created this revision.Aug 21 2021, 4:59 PM
siger-young requested review of this revision.Aug 21 2021, 4:59 PM
Herald added a project: Restricted Project. · View Herald TranscriptAug 21 2021, 4:59 PM
tammela accepted this revision.Aug 23 2021, 8:43 AM

LGTM

This revision is now accepted and ready to land.Aug 23 2021, 8:43 AM
mstorsjo added inline comments.
lldb/cmake/modules/FindLuaAndSwig.cmake
12

This breaks building in setups where SWIG is available, but not Lua. Previously this detected Lua and took it into use if both Lua and SWIG were available, and if not , proceeded without them.

mstorsjo added inline comments.Sep 3 2021, 2:20 AM
lldb/cmake/modules/FindLuaAndSwig.cmake
12

Just removing the REQUIRED from here seems to fix my build. Or I could just revert the patch to return to discussing how it should be done.

I'm doing either of them fairly soon in any case, to unbreak my build.

siger-young added inline comments.Sep 3 2021, 2:33 AM
lldb/cmake/modules/FindLuaAndSwig.cmake
12

I think removing the "REQUIRED" flags might work. I will revert the broken commit first.

tammela added inline comments.Sep 3 2021, 7:10 PM
lldb/cmake/modules/FindLuaAndSwig.cmake
12

That's look OK

siger-young reopened this revision.Sep 26 2021, 12:33 AM
This revision is now accepted and ready to land.Sep 26 2021, 12:33 AM

Remove "REQUIRED" flags when finding Lua at "FindLuaAndSwig.cmake".

tammela accepted this revision.Sep 26 2021, 7:12 AM