We have 3 different mutexes (RWMutex, BlockingMutex __tsan::Mutex),
each with own set of downsides. I want to unify them under a name Mutex.
But it will conflict with Mutex in the deadlock detector,
which is a way too generic name. Rename it to MutexState.
Details
Details
- Reviewers
vitalybuka melver - Commits
- rG41ba96f53127: sanitizer_common: rename Mutex to MutexState
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo