As preparation for a subsequent diff that implements builtin section renaming, define more constexpr strings in namespaces lld::macho::segment_names and lld::macho::section_names, and use them to replace string literals.
Details
Details
- Reviewers
int3 - Group Reviewers
Restricted Project - Commits
- rG465204d63a71: [lld-macho][NFC] define more strings in section_names:: and segment_names::
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Unit Tests
Time | Test | |
---|---|---|
890 ms | x64 windows > lld.MachO::reproduce.s |
Event Timeline
lld/MachO/MergedOutputSection.cpp | ||
---|---|---|
58–60 | technically a change in an error message is a functional change :) It seems like we are lacking a test for this; could you add it in this diff? Also I think the flags would be more readable as hex values (there's to_hexString() in ScopedPrinter.h) |
lld/MachO/MergedOutputSection.cpp | ||
---|---|---|
58–60 | Oops. This change should migrate back into the builtin-section-renaming diff. |
clang-tidy: warning: invalid case style for variable 'const_'; cannot be fixed because 'const' would conflict with a keyword [readability-identifier-naming]
not useful