MCSymbolRefExpr variant kind for TLSCALL is prefixed with _ARM_ since it was originally implemented.
I'm currently implementing the X86_64 version(s) described here http://www.fsfla.org/~lxoliva/writeups/TLS/RFC-TLSDESC-x86.txt and noticed that the assembler for both of them is:
symbol@TLSCALL(%register)
I think it makes sense to rename VK_ARM_TLSCALL to VK_TLSCALL (this may also be true for TLSDESC) and implement the correct semantic action in the machine-dependent code. Any objections?