Page MenuHomePhabricator

[NFC][DA] Remove duplicate code in checkSrcSubscript and checkDstSubscript
ClosedPublic

Authored by zhongduo on Dec 5 2019, 12:51 PM.

Details

Summary

[DA] Move common code in checkSrcSubscript and checkDstSubscript to a
new function checkSubscript. This avoids duplicate code and possible
out of sync in the future.

Diff Detail

Event Timeline

zhongduo created this revision.Dec 5 2019, 12:51 PM
Herald added a project: Restricted Project. · View Herald TranscriptDec 5 2019, 12:51 PM
zhongduo retitled this revision from [DA] Remove duplicate code in checkSrcSubscript and checkDstSubscript to [NFC][DA] Remove duplicate code in checkSrcSubscript and checkDstSubscript.Dec 24 2019, 10:34 AM

@sebpop and @jmolloy can you please review the change?

sebpop accepted this revision.Dec 24 2019, 1:11 PM

This cleanup looks good to me.

This revision is now accepted and ready to land.Dec 24 2019, 1:11 PM
This revision was automatically updated to reflect the committed changes.