Note: WIP patch 3/3 to go with a RFC for the device RTL design (see D64218)
This NFCI patch includes the following cleanup steps:
- Rename loop.cu to worksharing.cpp.
- Adjust most of the code according to the LLVM coding style, especially wrt. variable and method names.
- Document parts of the code with doxygen comments.
- Wrap CUDA specific calls into __kmpc_impl_XXX functions and define them in an own target_impl.h file.
- Use macro generators to reduce code duplication.
Hmm, the file has name worksharing.cpp, here it is named worksharing.cu. Did you try to compile it?