Add a new gpu arch gfx906+sram-ecc for HIP.
It is similar to gfx906 but implies target feature sram-ecc enabled,
whereas gfx906 implies target sram-ecc disabled. Corresponding
option -mattr=[+|-]sram-ecc will be passed to llc based on the
From the rest of the changes I guess it's the former, but the syntax used can easily be interpreted as the later.
Perhaps change the feature name to sram_ecc and GPU name to something less verbose. gfx906se ?
It actually means +(SRAM-ECC).
There is actually documentation about what features are supported and their format
Since the name has been used in runtime, we cannot change that.
Not all combinations are useful, therefore this patch only supports the one that is known to be useful.
I am considering a more generic approach, but so far I do not see its necessity yet.