Currently getRelocTargetVA handles relocation expressions
for all targets at once, mixing the common expressions and
target-specific expressions.
This approach has noticeable disadvantages:
- When debugging the code for some target, expressions specific
to other targets are unuseful. It is harder to read when logic for all kinds
of target specific code is mixed in one place.
- If we do a mistake in code and will use expression specific for target A
for target B, current code would not catch that. It's perhaps unlikely to happen,
but still not as safe/isolated as it could be.
Since this code does not use anything target specific, I think
R_HEXAGON_GOT should not have HEXAGON prefix and can be renamed
and moved to the common handlers group.