Implement 16-bit microMIPS jump and adjust stack pointer instruction - JRADDIUSP.
Details
Details
Diff Detail
Diff Detail
Event Timeline
Comment Actions
LGTM with a couple naming changes for consistency with similar existing code.
lib/Target/Mips/MCTargetDesc/MipsMCCodeEmitter.cpp | ||
---|---|---|
354 | The other similar functions assert that the bits shifted out are zero. | |
lib/Target/Mips/MCTargetDesc/MipsMCCodeEmitter.h | ||
79 | 'Shr2' is inconsistent with the other shifted immediates. I think it should be called 'getUImm5Lsl2Encoding' as per getSimm19Lsl2Encoding() and similar. | |
lib/Target/Mips/MicroMipsInstrInfo.td | ||
7–9 | Similar to above: Should be uimm5_lsl2 for consistency with simm19_lsl2 and similar. |
'Shr2' is inconsistent with the other shifted immediates. I think it should be called 'getUImm5Lsl2Encoding' as per getSimm19Lsl2Encoding() and similar.