I am not sure why we have Lazy class, it seems to be an
excessive layer that only complicates things and does not
bring something very useful. I think we can remove it,
patch do that.
Details
Details
Diff Detail
Diff Detail
- Repository
- rLLD LLVM Linker
Event Timeline
Comment Actions
Generally looking good.
ELF/SymbolTable.cpp | ||
---|---|---|
583 | Please don't use auto. | |
ELF/SymbolTable.h | ||
80–82 | I don't think they are good name. Maybe each name makes sense, but we should avoid naming two functions very similar names. I'd just inline fetchLazy. | |
ELF/Symbols.h | ||
251–253 | "represents a symbols" -> "represent a symbol" |
This is a bit worse than before, but I'll fix this after you commit it.