Avoid using magic number in the code everywhere.
|35 ↗||(On Diff #121847)|
nit: could you call this ErrorCode? The plural doesn't make so much sense as a type name.
|42 ↗||(On Diff #121847)|
serverErrorStart/End are not error codes, they're for comparing the numeric values to a range.
Given this is an enum class and we have to cast to int to do comparisons, I don't think these belong inside the enum, but rather as ints, outside it.
However, these limits aren't used at all yet, so probably just remove them for now.