Page MenuHomePhabricator

Wrap .subsections_via_symbols directives in #if __APPLE__

Authored by jroelofs on May 9 2014, 2:16 PM.


Diff Detail

Event Timeline

jroelofs updated this revision to Diff 9274.May 9 2014, 2:16 PM
jroelofs retitled this revision from to Wrap .subsections_via_symbols directives in #if __APPLE__.
jroelofs updated this object.
jroelofs edited the test plan for this revision. (Show Details)
jroelofs added a reviewer: t.p.northover.
jroelofs added a subscriber: Unknown Object (MLST).
rnk added a subscriber: rnk.May 9 2014, 2:38 PM

Maybe define a macro that completely wraps .subsections_via_symbols for

Reed, care to bikeshed on a name? I'm drawing a blank.

Another option I considered was to add FILE_LEVEL_DIRECTIVE to the definition of DEFINE_COMPILERRT_PRIVATE_FUNCTION (just like DEFINE_COMPILERRT_FUNCTION has), and delete all of these. I'm not sure if that is correct though as there are a few other builtins that don't have .subsections_via_symbols.

I think that adding that to DEFINE_COMPILERRT_PRIVATE_FUNCTION should be
okay. The only place that this is used currently is when you are defining
a private function.

jroelofs updated this revision to Diff 9318.May 12 2014, 9:27 AM

Move .subsections_via_symbols into definition of DEFINE_COMPILERRT_PRIVATE_FUNCTION.

compnerd accepted this revision.May 12 2014, 9:38 AM
compnerd added a reviewer: compnerd.
This revision is now accepted and ready to land.May 12 2014, 9:38 AM

Committed r208603.

jroelofs closed this revision.May 12 2014, 11:01 AM