Slightly improve the diagnostic by including the function name.
This has been separated out from https://reviews.llvm.org/D33945.
Just one minor comment.
I think it's better to use NamedDecl to allow this function be used for declarations other than FunctionDecl.
Making that change, going to re-run the tests and then I'll commit.