This is a much more flexible API and necessary in the new loop unswitch
to reasonably support both new and old PMs in common code. It also just
seems like a cleaner separation of concerns.
NFC, this should just be a pure refactoring.
Paths
| Differential D33528
[LegacyPM] Make the 'addLoop' method accept a loop to add rather than having it internally allocate the loop. ClosedPublic Authored by chandlerc on May 24 2017, 5:39 PM.
Details Summary This is a much more flexible API and necessary in the new loop unswitch NFC, this should just be a pure refactoring.
Diff Detail
Event TimelineComment Actions This is fine assuming you audited all the callers (a quick grep shows just these two).
This revision is now accepted and ready to land.May 24 2017, 5:46 PM Comment Actions Thanks, landing!
Yeah, my grep concludes the same.
Closed by commit rL303834: [LegacyPM] Make the 'addLoop' method accept a loop to add rather than (authored by chandlerc). · Explain WhyMay 24 2017, 8:01 PM This revision was automatically updated to reflect the committed changes. chandlerc marked an inline comment as done.
Revision Contents
Diff 100198 llvm/trunk/include/llvm/Analysis/LoopPass.h
llvm/trunk/lib/Analysis/LoopPass.cpp
llvm/trunk/lib/Transforms/Scalar/InductiveRangeCheckElimination.cpp
llvm/trunk/lib/Transforms/Scalar/LoopUnswitch.cpp
|