There was 3 visible problem this patch trying to fix:
- RelocAddrMap was defined at 2 difference files at once. I moved definition to DWARFRelocMap.h.
- RelocAddrMap was a pair of <width, address>, where width is relocation size (4/8), and width field was never used in code.
- Relocations proccessing loop had checks for width field. I don't think DWARF parser should do that. There is probably no much sense to validate relocations during proccessing them in parser.
Patch moves definition to single file, stops storing width field, stops doing additional checks during handling
of relocations, that all together simplifies the code.