Split out formatting and style changes from D26061
Details
Diff Detail
- Repository
- rL LLVM
Event Timeline
I am not a big fan of loosing svn blame only to fix formatting, but since you are modifying this code anyway, it's fine by me.
Artem and Devin, what is your opinion on this?
lib/StaticAnalyzer/Core/RangeConstraintManager.cpp | ||
---|---|---|
459 ↗ | (On Diff #78054) | We should use lower case function names. |
lib/StaticAnalyzer/Core/SimpleConstraintManager.cpp | ||
228 ↗ | (On Diff #78054) | I don't think we should change the case in the comment. |
255 ↗ | (On Diff #78054) | Not sure the comment needs to change. |
I agree that in general it is not good to lose the annotation information, but if you're fine with it I'm fine with it.
Un-change comments, misc. changes
lib/StaticAnalyzer/Core/RangeConstraintManager.cpp | ||
---|---|---|
459 ↗ | (On Diff #78054) | Are you saying more functions should be changed to lowercase (e.g. intersect)? Or that getRange should be getrange? |
lib/StaticAnalyzer/Core/RangeConstraintManager.cpp | ||
---|---|---|
459 ↗ | (On Diff #78054) | Should be "camel case, and start with a lower case letter", see: http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly |
lib/StaticAnalyzer/Core/RangeConstraintManager.cpp | ||
---|---|---|
459 ↗ | (On Diff #78054) | Right, isn't changing GetRange to getRange correct then? I'm a little confused, is there something else that needs to be fixed? |
Thank you!
lib/StaticAnalyzer/Core/RangeConstraintManager.cpp | ||
---|---|---|
459 ↗ | (On Diff #78054) | Sorry, my bad. This does look good! |