This patch also removes the SCEV variants of getStepVector() since they have no uses after the refactoring. This change was suggested in the review of D21620.
Great clean-up! I have a few minor suggestions below.
Can we do a single look-up in an assert-enabled build? I.e. assert(II != end() ...)
Init is a bit confusing in this context. How about ScalarIV? I think that you can also move this down to after the call to createVectorIntInductionPHI.
I would rename II to ID or something since it's not an iterator but an InductionDescriptor.