made checking for invalid cache entries and setting invalid cache
entries more implicit and clear.
Details
Details
- Reviewers
Chia-hungDuan cferris - Commits
- rGa0b9f1f84b33: [scudo] set/check invalid cache entries
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
compiler-rt/lib/scudo/standalone/secondary.h | ||
---|---|---|
85 | Sorry, really small nit pick here, but I think just naming this invalidate is better. As you can see below you have code like: Entry[].invalidateEntry(); Where it seems to make more sense as: Entry[].invalidate(); Since you don't use isValidEntry() in the other name it feels better to have them both have Entry or neither have Entry. I'd prefer neither have Entry. |
Comment Actions
changed name of invalidateEntry() to invalidate() to be more concise and less repetitive.
Sorry, really small nit pick here, but I think just naming this invalidate is better. As you can see below you have code like:
Where it seems to make more sense as:
Since you don't use isValidEntry() in the other name it feels better to have them both have Entry or neither have Entry. I'd prefer neither have Entry.