Per discussions on the mailing list, I have implemented a decorator which annotates individual
test methods with categories. I have used this framework to replace the '-a' and '+a'
command-line switches (now '-G pyapi' and '--skip-category pyapi') and the @python_api_test
decorator (now @categories('pyapi')). The test suite now gives an error message suggesting the
new options if the user specifies the deprecated +/-a switches. If the general direction is good,
I will follow this up with other switches.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM
Event Timeline
Comment Actions
Could you call this something less generic than categories? The name of the decorator should be descriptive enough to hint that it can only be applied to test methods. test_categories even.