Previously, we stored a pointer from the ObjFile to its compact unwind
section in order to avoid iterating over the file's sections a second
time. However, given the small number of sections (not subsections) per
file, this caching was really quite unnecessary. We will soon do lookups
for more sections (such as the __eh_frame section), so let's simplify
the code first.
Details
Details
- Reviewers
Roger - Group Reviewers
Restricted Project - Commits
- rGe6382d23fcc8: [lld-macho][nfc] Simplify unwind section lookup
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
lld/MachO/InputFiles.cpp | ||
---|---|---|
919 | It looks like we do not use this variable aside from assigning to it. Can we get rid of it? |
lld/MachO/InputFiles.cpp | ||
---|---|---|
919 | it's used in the next diff, I don't think finagling with merge conflicts just to relocate it there is worthwhile :P |
lld/MachO/InputFiles.cpp | ||
---|---|---|
919 | Sounds good. |
It looks like we do not use this variable aside from assigning to it. Can we get rid of it?