Patch should be fairly self-explanatory. Implementation is empty on non-Windows platforms, and on Windows platforms simply calls CoInitializeEx and CoUninitialize.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM
Event Timeline
Comment Actions
Do we do that for any other types of these classes? For example, there's llvm_shutdown_obj, scoped_ptr? I don't feel too strongly either way, but if this is a desirable naming convention then we shoudl think about formalizing it.
Comment Actions
Sure: NewQueueRAII, TemplateParameterDepthRAII, ContextRAII, FPContractStateRAII, CompoundScopeRAII, CXXThisScopeRAII, ArgumentPackSubstitutionIndexRAII, etc.