Distributions that put lldb binaries in /usr/bin and whatnot are going to put argdumper in the same place. argdumper is way too generic a name. Rename to lldb-argdumper, to match our lldb- prefix for lldb executables.
This change fixes the Xcode and cmake builds to use lldb-argdumper as the binary name.
I've tested this patch on OS X 10.11 and Ubuntu 14.04 x86_64.
I will make follow-up changes (after verifying the name change works) to:
- eliminate the dependence on liblldb - that is silly for this binary.
- rename the directory and source file names to match lldb-argdumper.
I'd rather break this into an end-product change (this one) and the file/directory naming change rather than jam those together.