Change-Id: I9985d72191a2b0680195032acf8a14ad2ba954ed
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Comment Actions
Yeah, looks good - generally no need to send things like this sort of cleanup for review (can be committed directly/for post-commit review).
I guess this could even be replaced by something like:
return llvm::none_of(*entrySuccs, [&](BlockT* successor) { return successor != exit && successor != entry; });
Not sure if that's better/more readable or not, up to you.