Page MenuHomePhabricator

[lldb] Fix TestErrorMessages test on standalone builds by adding lldb-server substitution
ClosedPublic

Authored by teemperor on Nov 10 2020, 5:49 AM.

Details

Summary

It seems that TestErrorMessages.test is failing on the standalone + Xcode builds as lldb-server executable
can't be found by lit's default PATH search. I assume invoking lldb-server via a lit substitution
gets this working again as everything else is working, so that's what this patch is doing.

I had to add the lldb-server substitution as the test seems lldb-server specific and we don't want it to default
to debugserver on Darwin.

Using a substitution also seems in general like a good idea so that the commands lit is printing on failure
are using the full path to lldb-server and can be re-run in a terminal.

Diff Detail

Event Timeline

teemperor requested review of this revision.Nov 10 2020, 5:49 AM
teemperor created this revision.
labath accepted this revision.Nov 10 2020, 5:59 AM
labath added inline comments.
lldb/test/Shell/helper/toolchain.py
65–68

I guess we don't need this then, as one can just write %lldb-server platform. It also seems to be unused.

This revision is now accepted and ready to land.Nov 10 2020, 5:59 AM
Herald added a project: Restricted Project. · View Herald TranscriptNov 10 2020, 6:26 AM
teemperor added inline comments.Nov 10 2020, 6:53 AM
lldb/test/Shell/helper/toolchain.py
65–68

It seems the test that was using this substitution was accidentally deleted in the lldb-mi removal, so I reinstated that test.

JDevlieghere reopened this revision.Nov 10 2020, 8:39 AM

Please add a _disallow to avoid accidental use of lldb-server without the %.

This revision is now accepted and ready to land.Nov 10 2020, 8:39 AM
teemperor closed this revision.Nov 10 2020, 9:52 AM

Added the disallow in rG7211604220ae