- Added a dedicated completion to class CommandObjectTypeFormatterDelete which can be used by these commands: type filter/format/summary/synthetic delete;
- Added a related test case.
I just realized those patches probably conflict with the refactoring I'm doing with that code at the moment. I'll take care of the conflicts in your patches, but if you can push them back and maybe do other completions first then that would help a lot :)
Please make this a Doxygen comment (///).
This is a lot of code duplication. Cann you hide this behind a macro? I'm thinking of something like:
#define CHECK_MASK(MASK, VALUE) MASK & VALUE == VALUE