Page MenuHomePhabricator

Target Ivy bridge on macOS Mojave and later
AbandonedPublic

Authored by davezarzycki on Nov 5 2019, 4:17 AM.

Details

Summary

Ivy Bridge is required by macOS 10.14 (Mojave) and later.

Diff Detail

Event Timeline

davezarzycki created this revision.Nov 5 2019, 4:17 AM

Hi @bob.wilson – Am I missing something here?

@bob.wilson – Ping. While Ivy Bridge (or really, Sandy Bridge) has AVX1, which enables faster memcpy, memset, and even memcmp (for common scenarios). If there is something I'm missing? If you can't explain why, that's okay. :-)

arphaman added a subscriber: arphaman.

@bob.wilson no longer works on llvm-project. I added Gerolf and Duncan.

dexonsmith requested changes to this revision.Nov 12 2019, 10:30 AM

Hi Dave, thanks for checking in on this, but unfortunately we're not ready for this yet.

This revision now requires changes to proceed.Nov 12 2019, 10:30 AM
Gerolf resigned from this revision.Nov 12 2019, 10:33 AM
Gerolf added a reviewer: grosbach.
davezarzycki abandoned this revision.Nov 12 2019, 10:58 PM

Okay. I'm going to abandon this patch on the assumption that Apple has an internal bug tracking this.