This patch only touched variables and functions in target.
Should be easy to address my comments and let us get this merged ASAP.
"Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo())."
Since we are anyway changing the names. Let us fix them fully.
Let us kill the pain in one shot. It is just a few more sed.