Page MenuHomePhabricator

[clang-tidy] Rename objc-avoid-spinlock check to darwin-avoid-spinlock
ClosedPublic

Authored by mwyman on Sep 27 2019, 11:02 AM.

Details

Summary

OSSpinLock* are Apple/Darwin functions, but were previously located with ObjC checks as those were most closely tied to Apple platforms before.

Now that there's a specific Darwin module, relocating the check there.

This change was prepared by running rename_check.py.

Diff Detail

Repository
rL LLVM

Event Timeline

mwyman created this revision.Sep 27 2019, 11:02 AM
mwyman edited the summary of this revision. (Show Details)Sep 27 2019, 11:03 AM
Eugene.Zelenko added inline comments.
clang-tools-extra/docs/ReleaseNotes.rst
70 โ†—(On Diff #222206)

Please place this after list of new checks. If there are other renamed checks, please keep alphabetical order in that list.

mwyman updated this revision to Diff 222253.Sep 27 2019, 3:02 PM

Moved release note below list of new checks.

mwyman marked an inline comment as done.Sep 27 2019, 3:02 PM
stephanemoore accepted this revision.Sep 29 2019, 4:32 PM

I wasn't sure what the policy is for renaming checks so I dug into previous check renames. https://reviews.llvm.org/D43867 seems to indicate that it's acceptable for checks to be renamed with documentation in the release notes (though there is some discussion about the possibility of recognizing the old check name for a grace period). Based on the aforementioned precedent I don't have concerns with this proposed change.

LGTM ๐Ÿ‘Œ

This revision is now accepted and ready to land.Sep 29 2019, 4:32 PM
This revision was automatically updated to reflect the committed changes.