DwarfException served as a base class for exception handling directive emission.
However, this is also used by other exception models (e.g. Win64EH). Rename
this class to EHStreamer and split it out of DwarfException.h. NFC.
Use the opportunity to fix up some of the documentation comments to match
current LLVM style. Also rename some functions to conform better with current
LLVM coding style.
It would be a shame to do this mass move and not take the opportunity to rename this "sharedTypeIds" to match the LLVM style guide.
Similarly for the other functions here. Most of them seem fairly localised.