There are a few reasons for this change:
- Support generic logic flow for different socket types - a preparation step to support domain sockets in lldb-server along with TCP.
- Offload Socket.cpp and make it more readable and serving more as a factory class.
- Move out protocol-specific members like m_udp_send_sockaddr to more fine-grained classes.
I would rename these to something more neutral like name, addr, etc. as this will not be a host+port for the domain socket implementation.