It is now obsolete because the method mustExecuteInLoop does exactly the same thing in a cleaner OOP style.
Hold this one please. I have some concerns about the naming, but have lost track of the dependent patches and can't fully review. Once dependent changes have landed, let's revisit.
Abandoned per https://reviews.llvm.org/rL344587.