Page MenuHomePhabricator

[Driver] Rename GetNamedOutputPath() to addNamedOutputPath()
Needs ReviewPublic

Authored by jgorbe on Apr 26 2017, 5:19 PM.

Details

Reviewers
echristo
Summary

The current name is confusing: it looks like it should just compute the path and return it but it has the side effect of appending it to the compilation's list of result files. This change changes the verb in the method name from "get" to "add" to emphasize this side effect.

Diff Detail

Event Timeline

jgorbe created this revision.Apr 26 2017, 5:19 PM