These accessors maps directly to the command line option.
Details
Details
- Reviewers
steven_wu - Commits
- rG6683e22c25ad: Split isUsingLTO() outside of embedBitcodeInObject() and embedBitcodeMarkerOnly…
rC292960: Split isUsingLTO() outside of embedBitcodeInObject() and embedBitcodeMarkerOnly…
rL292960: Split isUsingLTO() outside of embedBitcodeInObject() and embedBitcodeMarkerOnly…
Diff Detail
Diff Detail
- Build Status
Buildable 3224 Build 3224: arc lint + arc unit
Event Timeline
Comment Actions
I think you should add a new API for embedBitcodeMarkerEnabled() or revert the name the APIs to before https://reviews.llvm.org/rL287084.
Comment Actions
I'm missing where rL287084 changed the name? It introduced a new API but didn't rename anything AFAICT, here is what it was before:
bool embedBitcodeEnabled() const { return BitcodeEmbed == EmbedBitcode; } bool embedBitcodeEnabled() const { return BitcodeEmbed != EmbedNone; }
Comment Actions
Depending on how you look at the previous commit, you can think that as a new API or just rename the old API. I actually dont think there is too much issue names. Plz go ahead.
Comment Actions
Sorry I just notice that when I look at driver today.
cfe/trunk/lib/Driver/Tools.cpp | ||
---|---|---|
6464 ↗ | (On Diff #85605) | Should this line actually be: !(C.getDriver().embedBitcodeInObject() && !C.getDriver().isUsingLTO()) && |
cfe/trunk/lib/Driver/Tools.cpp | ||
---|---|---|
6464 ↗ | (On Diff #85605) | Thanks, r293370 |