Page MenuHomePhabricator

Rename clang_type_t to opaque_t.

Authored by brucem on Sep 21 2015, 5:19 PM.


Diff Detail

Event Timeline

brucem updated this revision to Diff 35326.Sep 21 2015, 5:19 PM
brucem retitled this revision from to Rename clang_type_t to opaque_t..
brucem updated this object.
brucem added a reviewer: clayborg.
brucem added a subscriber: lldb-commits.

I think this might be better as opaque_compiler_type_t or something. It is longer, but if we switch the opaque decls over, it is confusing to have the types have the same name, I think.

brucem updated this revision to Diff 35339.Sep 21 2015, 8:08 PM

Rename to opaque_compiler_type_t instead.

clayborg accepted this revision.Sep 22 2015, 9:21 AM
clayborg edited edge metadata.

Looks good. We should switch all of TypeSystem's methods over to use this instead of "void *" as well in a future commit.

This revision is now accepted and ready to land.Sep 22 2015, 9:21 AM

I already have that as a commit lined up. Just wanted this to land separately first. :)

This revision was automatically updated to reflect the committed changes.