I think this would read better as:
Don't emit any warnings for unused driver arguments.
Agreed. I will make this change.
Apply majnemer's edit to the description of -Qunused-arguments.
Could just be "Do not emit warnings for unused driver arguments"
Either way is OK, I think - but use "Do not" instead of don't.
Use "Do not" instead of "don't" as suggested by mclow.
Committed as SVN r239652. Thanks!